Security Upgrade on June 25, 2018

We here at SolidTrust Pay do everything we can to ensure our security and yours. Since security threats are always evolving, we have to do the same to keep our security measures up to date.

On June 25 we will be making some updates that may affect users with older browsers and operating systems.

SolidTrust Pay will no longer be supporting TLS 1.0 due to the depreciation of this encryption protocol. Going forward only TLS 1.1 and 1.2 will be supported.

This means that people using older versions of web browsers may have trouble connecting to Solidtrustpay.com after the change.

At a minimum, the following versions of web browsers are required:

Google Chrome Version 22

Mozilla Firefox version 23*

Internet Explorer version 8*

Apple Safari version 7

Opera browser version 8*

 

*These versions do not have TLS 1.1 support enabled by default and must be manually turned on

 

If you have problems connecting to Solidtrustpay.com, please make sure you upgrade your web browser to its latest version. If you have any questions or concerns, please contact customer support at https://support.solidtrustpay.com/